Moodle 2.5 or later requires at least PHP 5.3.3 (currently using version 5.2.9).
Please upgrade your server software or install older Moodle version.